Go Back   Customers Suck! > The Heart of the Site > Unsupportable > Tech help

Reply
 
Thread Tools Display Modes

Linux Gurus -- I need you again...
  #1  
Old 05-24-2020, 05:00 PM
mjr's Avatar
mjr mjr is online now
Area Manager
 
Join Date: Jan 2013
Location: 127.0.0.1
Posts: 1,060
Default Linux Gurus -- I need you again...

I have no idea where to start here. I have an Ubuntu Linux machine with two HDDs in it. It's a newer Linux version (19, I think, I'll have to look) The primary drive works fine, but I have one named ThreeT (for Three Terabyte).

I have (or had, anyway) this drive "shared out" to my Windows network. The problem is, for some reason, I can no longer access it via my Windows network. And when I go to my Linux file explorer (whatever it's called, I forget) I can see the drive, but when I click on it to access it, the tab name shows "ThreeT1" (a 1 is appended). I can access the files there, but only on my Linux computer, not from my Windows one.

Any ideas on how to fix this? I'm hoping that the drive isn't becoming corrupted or something.
__________________
Skilled programmers aren't cheap. Cheap programmers aren't skilled.
Reply With Quote

  #2  
Old 05-24-2020, 09:50 PM
RealUnimportant's Avatar
RealUnimportant RealUnimportant is offline
Ex-Puncher of Tickets
 
Join Date: Aug 2011
Location: 13A, Moonbase Beaver.
Posts: 2,166
Default

I would presume that whatever caused the name to be changed has broken whatever sharing or link association made the drive accessible from Windows. Can you rename it back so it loses the 1?
__________________
This was one of those times where my mouth says "have a nice day" but my brain says "go step on a Lego". - RegisterAce
I can't make something magically appear to fulfill all your hopes and dreams. Believe me, if I could I'd be the first person I'd help. - Trixie
Reply With Quote

  #3  
Old 05-25-2020, 01:49 AM
mjr's Avatar
mjr mjr is online now
Area Manager
 
Join Date: Jan 2013
Location: 127.0.0.1
Posts: 1,060
Default

Quote:
Quoth RealUnimportant View Post
I would presume that whatever caused the name to be changed has broken whatever sharing or link association made the drive accessible from Windows. Can you rename it back so it loses the 1?
I don't know how.

What's weird is when I pull up the file explorer in Linux, the drive is listed as ThreeT.

However, when I click on ThreeT in Linux, and it opens in a new tab, it opens as ThreeT1.

I wish I knew some command or something to fix it.
__________________
Skilled programmers aren't cheap. Cheap programmers aren't skilled.
Reply With Quote

  #4  
Old 05-25-2020, 02:26 PM
csquared's Avatar
csquared csquared is offline
Loanshark IT
 
Join Date: May 2009
Location: On the verge of Cumming... GA
Posts: 1,542
Default

If the mountpoint got renamed, the Samba would not be able to find it.

If you are familiar with the linux command line, run "df -hP"
__________________
Life is too short to not eat popcorn.
Save the Ales!
Toys for Tots at Rooster's Cafe
Reply With Quote

  #5  
Old 05-25-2020, 02:32 PM
mjr's Avatar
mjr mjr is online now
Area Manager
 
Join Date: Jan 2013
Location: 127.0.0.1
Posts: 1,060
Default

Quote:
Quoth csquared View Post
If the mountpoint got renamed, the Samba would not be able to find it.

If you are familiar with the linux command line, run "df -hP"
Thanks! That certainly appears to be the case.

The entry shows something like this:

/dev/sda1 <size> <used> <available> /media/<my name>/ThreeT1

So how do I fix it?
__________________
Skilled programmers aren't cheap. Cheap programmers aren't skilled.

Last edited by mjr; 05-25-2020 at 02:35 PM.
Reply With Quote

  #6  
Old 08-07-2020, 03:08 PM
mjr's Avatar
mjr mjr is online now
Area Manager
 
Join Date: Jan 2013
Location: 127.0.0.1
Posts: 1,060
Default

Ok, back to this thread...

in /media/my_username there are three directories listed:

ThreeT1, ThreeT, and disk

The problem is, I didn't create ThreeT1. I just restarted the machine one day (I think after an update or something) and it was there, and I could no longer access ThreeT.

If I look at the permissions for ThreeT, it shows the owner and group as "root".

Under Access Control, Owner is set to "View and modify folder content", but Group and Other are set to "Forbidden", and I'm not able to change them, because I get a "permission denied" message when I try to.

So is there a way I can fix this without deleting files? What I'd like to do is either fix ThreeT, or to delete ThreeT and re-name ThreeT1 to ThreeT.

I'd like to do this before I do the upgrades I'm talking about in the other thread.
__________________
Skilled programmers aren't cheap. Cheap programmers aren't skilled.
Reply With Quote

  #7  
Old 08-08-2020, 08:58 AM
RealUnimportant's Avatar
RealUnimportant RealUnimportant is offline
Ex-Puncher of Tickets
 
Join Date: Aug 2011
Location: 13A, Moonbase Beaver.
Posts: 2,166
Default

Log in as root and fix the permissions there, or use sudo?
__________________
This was one of those times where my mouth says "have a nice day" but my brain says "go step on a Lego". - RegisterAce
I can't make something magically appear to fulfill all your hopes and dreams. Believe me, if I could I'd be the first person I'd help. - Trixie
Reply With Quote

  #8  
Old 08-08-2020, 12:06 PM
mjr's Avatar
mjr mjr is online now
Area Manager
 
Join Date: Jan 2013
Location: 127.0.0.1
Posts: 1,060
Default

Quote:
Quoth RealUnimportant View Post
Log in as root and fix the permissions there, or use sudo?
Awesome! That pointed me in the right direction and got me back where I needed to be!

Thank you very much!
__________________
Skilled programmers aren't cheap. Cheap programmers aren't skilled.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 01:58 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.